<!doctype html><html lang="en-us" dir="ltr"><head><meta charset="utf-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><script src="https://polyfill.io/v3/polyfill.min.js?flags=gated&amp;features=es6%2Ces7%2Cfetch%2CPromise.prototype.finally"></script><script src="/dist/js/index.2b881f50.js"></script><link rel="stylesheet" href="/dist/css/index.d1a9a497.css"><link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png"><link rel="manifest" href="/site.webmanifest"><script>var googletag = googletag || {}; googletag.cmd = googletag.cmd || [];</script><script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PNBSZL4');</script><script>
      (function (i, s, o, g, r, a, m) {
        i['FortnightObject'] = r; i[r] = i[r] || function () {
          (i[r].q = i[r].q || []).push(arguments)
        }, a = s.createElement(o),
        m = s.getElementsByTagName(o)[0]; a.async = 1; a.src = g; a.crossOrigin = 'anonymous'; m.parentNode.insertBefore(a, m)
      })(window, document, 'script', 'https://d24bnj4f1s1f8m.cloudfront.net/1.0.0-rc.4.3/fortnight.min.js', 'fortnight');
      fortnight('init', { domain: 'https://acbm.native-x.io' });
    </script><title>Curb Roller Manufacturing Releases Eel Screed 6100 | For Construction Pros</title><meta name="description" property="og:description" item-prop="description" content="The innovative design of the Eel Screed 6100 allows contractors, rental customers, and other operators to finish concrete screeding faster and more comfortably than alternate methods."><link rel="canonical" href="https://www.forconstructionpros.com/rental/inventory/press-release/21134411/curb-roller-manufacturing-curb-roller-manufacturing-releases-eel-screed-6100"><meta property="og:title" item-prop="name" content="Curb Roller Manufacturing Releases Eel Screed 6100"><meta name="image" property="og:image" item-prop="image" content="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/CurbRoller_EelScreed_1.5ec68a69aecaf.png?auto=format&amp;fit=max&amp;w=1200"><meta property="og:url" content="https://www.forconstructionpros.com/rental/inventory/press-release/21134411/curb-roller-manufacturing-curb-roller-manufacturing-releases-eel-screed-6100"><meta property="og:site_name" content="For Construction Pros"><meta property="og:locale" content="en"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Curb Roller Manufacturing Releases Eel Screed 6100"><meta name="twitter:description" content="The innovative design of the Eel Screed 6100 allows contractors, rental customers, and other operators to finish concrete screeding faster and more comfortably than alternate methods."><meta name="twitter:image:src" content="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/CurbRoller_EelScreed_1.5ec68a69aecaf.png?auto=format&amp;fit=max&amp;w=1200"><meta property="og:type" content="article"><meta property="article:published_time" content="May 21st, 2020"><meta property="article:modified_time" content="May 21st, 2020"><script>dataLayer.push({"page_type":"content","canonical_path":"/rental/inventory/press-release/21134411/curb-roller-manufacturing-curb-roller-manufacturing-releases-eel-screed-6100","query_string":"","content":{"id":21134411,"type":"press-release","name":"Curb Roller Manufacturing Releases Eel Screed 6100","published":"2020-05-21T14:15:21.000Z"},"created_by":{"id":"5eb017c2252c9f4e0a8b48ae","username":"abrumm@acbusinessmedia.com","firstName":"Alexis","lastName":"Brumm"},"company":{"id":10075324,"name":"Curb Roller Manufacturing"},"section":{"id":54510,"name":"Rental Inventory","alias":"rental/inventory","fullName":"Rental > Rental Inventory"},"section_hierarchy":[{"id":54497,"name":"Rental","alias":"rental"},{"id":54510,"name":"Rental Inventory","alias":"rental/inventory"}],"taxonomy":[{"id":3148451,"type":"Tag","name":"roller screed","fullName":"Tag: roller screed (3148451)"},{"id":3148450,"type":"Tag","name":"concrete work","fullName":"Tag: concrete work (3148450)"}],"authors":[]});</script><script>googletag.cmd.push(function() { googletag.pubads().setTargeting('cont_id', '21134411').setTargeting('cont_type', 'press-release'); });</script><script type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","headline":"Curb Roller Manufacturing Releases Eel Screed 6100","url":"https://www.forconstructionpros.com/rental/inventory/press-release/21134411/curb-roller-manufacturing-curb-roller-manufacturing-releases-eel-screed-6100","thumbnailUrl":"https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/CurbRoller_EelScreed_1.5ec68a69aecaf.png?auto=format&w=320","datePublished":"2020-05-21T14:15:21.000Z","articleSection":"Rental Inventory","keywords":["roller screed","concrete work"]}</script><script>googletag.cmd.push(function() { googletag.defineSlot('/21772951814/forconstructionpros/rental/lb1', [[970,250],[970,90],[970,66],[728,90],[320,50],[300,50],[300,100]], 'gpt-ad-lb1').defineSizeMapping(googletag.sizeMapping().addSize([980,0], [[970,250],[970,90],[970,66],[728,90]]).addSize([750,0], [728,90]).addSize([320,0], [[300,50],[320,50],[300,100]]).build()).setCollapseEmptyDiv(true).addService(googletag.pubads()); googletag.defineSlot('/21772951814/forconstructionpros/rental/lb1', [[970,250],[970,90],[970,66],[728,90],[320,50],[300,50],[300,100]], 'gpt-ad-lb2').defineSizeMapping(googletag.sizeMapping().addSize([980,0], [[970,250],[970,90],[970,66],[728,90]]).addSize([750,0], [728,90]).addSize([320,0], [[300,50],[320,50],[300,100]]).build()).setCollapseEmptyDiv(true).addService(googletag.pubads()); googletag.defineSlot('/21772951814/forconstructionpros/rental/rail1', [[300,250]], 'gpt-ad-rail1').setCollapseEmptyDiv(true).addService(googletag.pubads()); googletag.defineSlot('/21772951814/forconstructionpros/rental/rail1', [[300,600]], 'gpt-ad-rail2').setCollapseEmptyDiv(true).addService(googletag.pubads()); googletag.defineSlot('/21772951814/forconstructionpros/rental/rail1', [[300,250],[300,600]], 'gpt-ad-rail-infinite').defineSizeMapping(googletag.sizeMapping().addSize([992,0], [[300,250],[300,600]]).addSize([0,0], []).build()).setCollapseEmptyDiv(true).addService(googletag.pubads()); });</script><script>dataLayer.push({"gtm.start":1590072144604,"event":"gtm.js"});</script><script>googletag.cmd.push(function() { googletag.pubads().enableSingleRequest(); googletag.pubads().collapseEmptyDivs(); googletag.pubads().setTargeting('path', '/rental/inventory/press-release/21134411/curb-roller-manufacturing-curb-roller-manufacturing-releases-eel-screed-6100').setTargeting('host', 'www|forconstructionpros|com').setTargeting('env', 'production'); googletag.enableServices(); });</script><script>googletag.cmd.push(function() { googletag.pubads().setTargeting('uri', '/rental/inventory/press-release/21134411/curb-roller-manufacturing-curb-roller-manufacturing-releases-eel-screed-6100'); });</script></head><body><aside id="leaders-dropdown-portal-target" class="leaders-dropdown-portal"></aside><div id="vue-1590072144604-318"><script>CMSBrowserComponents.loadComponent('#vue-1590072144604-318', 'RevealAdListener', {"selectAllTargets":true});</script></div><div id="vue-1590072144604-856"><script>CMSBrowserComponents.loadComponent('#vue-1590072144604-856', 'TriggerScreenChangeEvent', {});</script></div><div id="vue-1590072144604-302"><script>CMSBrowserComponents.loadComponent('#vue-1590072144604-302', 'GTMTrackBusEvent', {"on":"screen_change"});</script></div><div id="vue-1590072144604-467"><script>CMSBrowserComponents.loadComponent('#vue-1590072144604-467', 'GTMTrackLoadMore', {});</script></div><div id="vue-1590072144604-349"><script>CMSBrowserComponents.loadComponent('#vue-1590072144604-349', 'RadixInquiryListener', {"appId":"4448cfcb-e2da-40ff-8be6-671110964914","submissionFieldIds":[{"name":"comments","id":"580f6d056cdeea4730ddbb2c"}]});</script></div><header class="site-header"><nav class="site-navbar site-navbar--secondary"><div class="site-navbar__container"><div id="vue-1590072144604-647"><script>CMSBrowserComponents.loadComponent('#vue-1590072144604-647', 'DefaultThemeMenuToggleButton', {"className":"site-navbar__toggler","targets":[".site-menu"],"toggleClass":"site-menu--open","iconModifiers":["lg"]});</script></div><a href="/" class="site-navbar__brand"><img class="site-navbar__logo" alt="For Construction Pros" src="https://base.imgix.net/files/base/acbm/fcp/image/static/logo/site_logo.png?h=45" srcset="https://base.imgix.net/files/base/acbm/fcp/image/static/logo/site_logo.png?h=90 2x"></a><ul class="site-navbar__items site-navbar__items--secondary"><li class="site-navbar__item"><a href="/equipment" class="site-navbar__link"><span class="site-navbar__label">Equipment</span></a></li><li class="site-navbar__item"><a href="/rental" class="site-navbar__link site-navbar__link--active"><span class="site-navbar__label">Rental</span></a></li><li class="site-navbar__item"><a href="/concrete" class="site-navbar__link"><span class="site-navbar__label">Concrete</span></a></li><li class="site-navbar__item"><a href="/asphalt" class="site-navbar__link"><span class="site-navbar__label">Asphalt</span></a></li><li class="site-navbar__item"><a href="/business" class="site-navbar__link"><span class="site-navbar__label">Business</span></a></li><li class="site-navbar__item"><a href="/construction-technology" class="site-navbar__link"><span class="site-navbar__label">Technology</span></a></li><li class="site-navbar__item"><a href="/profit-matters" class="site-navbar__link"><span class="site-navbar__label">Profit Matters</span></a></li></ul><ul class="site-navbar__items site-navbar__items--tertiary"><li class="site-navbar__item"><a href="/magazine" class="site-navbar__link"><span title="Magazine" class="marko-web-icon marko-web-icon--book site-navbar__icon"><svg xmlns="http://www.w3.org/2000/svg" width="16" height="16" viewBox="0 0 16 16"><path fill-rule="evenodd" d="M3 5h4v1H3V5zm0 3h4V7H3v1zm0 2h4V9H3v1zm11-5h-4v1h4V5zm0 2h-4v1h4V7zm0 2h-4v1h4V9zm2-6v9c0 .55-.45 1-1 1H9.5l-1 1-1-1H2c-.55 0-1-.45-1-1V3c0-.55.45-1 1-1h5.5l1 1 1-1H15c.55 0 1 .45 1 1zm-8 .5L7.5 3H2v9h6V3.5zm7-.5H9.5l-.5.5V12h6V3z"/></svg></span><span class="site-navbar__label">Magazine</span></a></li><li class="site-navbar__item"><a href="https://acbusiness.dragonforms.com/loading.do?omedasite=FCP_prefs_ProgReg" target="_blank" rel="noopener" class="site-navbar__link"><span title="Newsletter" class="marko-web-icon marko-web-icon--mail site-navbar__icon"><svg xmlns="http://www.w3.org/2000/svg" width="14" height="16" viewBox="0 0 14 16"><path fill-rule="evenodd" d="M0 4v8c0 .55.45 1 1 1h12c.55 0 1-.45 1-1V4c0-.55-.45-1-1-1H1c-.55 0-1 .45-1 1zm13 0L7 9 1 4h12zM1 5.5l4 3-4 3v-6zM2 12l3.5-3L7 10.5 8.5 9l3.5 3H2zm11-.5l-4-3 4-3v6z"/></svg></span><span class="site-navbar__label">Newsletter</span></a></li><li class="site-navbar__item"><a href="/search" class="site-navbar__link"><span title="Search" class="marko-web-icon marko-web-icon--search site-navbar__icon"><svg xmlns="http://www.w3.org/2000/svg" width="16" height="16" viewBox="0 0 16 16"><path fill-rule="evenodd" d="M15.7 13.3l-3.81-3.83A5.93 5.93 0 0 0 13 6c0-3.31-2.69-6-6-6S1 2.69 1 6s2.69 6 6 6c1.3 0 2.48-.41 3.47-1.11l3.83 3.81c.19.2.45.3.7.3.25 0 .52-.09.7-.3a.996.996 0 0 0 0-1.41v.01zM7 10.7c-2.59 0-4.7-2.11-4.7-4.7 0-2.59 2.11-4.7 4.7-4.7 2.59 0 4.7 2.11 4.7 4.7 0 2.59-2.11 4.7-4.7 4.7z"/></svg></span><span class="site-navbar__label">Search</span></a></li></ul></div></nav><nav class="site-navbar site-navbar--primary"><div class="site-navbar__container"><ul class="site-navbar__items site-navbar__items--primary"><li class="site-navbar__item"><a href="/rental/lifting-equipment" class="site-navbar__link"><span class="site-navbar__label">Lifting</span></a></li><li class="site-navbar__item"><a href="/rental/lifting-equipment/telescopic-handler" class="site-navbar__link"><span class="site-navbar__label">Telescopic Lifts</span></a></li><li class="site-navbar__item"><a href="/rental/lifting-equipment/boom-lift" class="site-navbar__link"><span class="site-navbar__label">Boom Lifts</span></a></li><li class="site-navbar__item"><a href="/rental/lifting-equipment/crane" class="site-navbar__link"><span class="site-navbar__label">Crane</span></a></li><li class="site-navbar__item"><a href="/rental/inventory" class="site-navbar__link site-navbar__link--active"><span class="site-navbar__label">Inventory</span></a></li></ul></div></nav></header><aside class="site-menu"><div class="site-menu__contents"><div class="site-menu__section"><div class="site-menu__header">Topics</div><ul class="site-menu__items"><li class="site-menu__item"><a href="/equipment" class="site-menu__link"><span class="site-menu__label">Equipment</span></a></li><li class="site-menu__item"><a href="/rental" class="site-menu__link site-menu__link--active"><span class="site-menu__label">Rental</span></a></li><li class="site-menu__item"><a href="/concrete" class="site-menu__link"><span class="site-menu__label">Concrete</span></a></li><li class="site-menu__item"><a href="/asphalt" class="site-menu__link"><span class="site-menu__label">Asphalt</span></a></li><li class="site-menu__item"><a href="/business" class="site-menu__link"><span class="site-menu__label">Business</span></a></li><li class="site-menu__item"><a href="/construction-technology" class="site-menu__link"><span class="site-menu__label">Technology</span></a></li><li class="site-menu__item"><a href="/profit-matters" class="site-menu__link"><span class="site-menu__label">Profit Matters</span></a></li></ul></div><div class="site-menu__section"><div class="site-menu__header">Resources</div><ul class="site-menu__items"><li class="site-menu__item"><a href="/directory" class="site-menu__link"><span class="site-menu__label">New Equipment Directory</span></a></li><li class="site-menu__item"><a href="/asphalt-industry-directory" class="site-menu__link"><span class="site-menu__label">Asphalt Industry Directory</span></a></li><li class="site-menu__item"><a href="/economics" class="site-menu__link"><span class="site-menu__label">Economics</span></a></li><li class="site-menu__item"><a href="/specguide" class="site-menu__link"><span class="site-menu__label">Spec Guides</span></a></li><li class="site-menu__item"><a href="/video" class="site-menu__link"><span class="site-menu__label">Video Network</span></a></li><li class="site-menu__item"><a href="/magazine" class="site-menu__link"><span class="site-menu__label">Magazine</span></a></li><li class="site-menu__item"><a href="/events" class="site-menu__link"><span class="site-menu__label">Events</span></a></li><li class="site-menu__item"><a href="https://www.constructionnetworkmediakit.com/" target="_blank" rel="noopener" class="site-menu__link"><span class="site-menu__label">Advertise</span></a></li></ul></div><div class="site-menu__section"><div class="site-menu__header">User Tools</div><ul class="site-menu__items"><li class="site-menu__item"><a href="#" target="_blank" rel="noopener" class="site-menu__link"><span class="site-menu__label">Newsletters</span></a></li><li class="site-menu__item"><a href="https://www.constructionnetworkmediakit.com/" target="_blank" rel="noopener" class="site-menu__link"><span class="site-menu__label">Advertise</span></a></li><li class="site-menu__item"><a href="/magazine" class="site-menu__link"><span class="site-menu__label">Current Issue</span></a></li><li class="site-menu__item"><a href="/contact-us" class="site-menu__link"><span class="site-menu__label">Contact Us</span></a></li><li class="site-menu__item"><a href="/page/privacy-policy" target="_blank" rel="noopener" class="site-menu__link"><span class="site-menu__label">Privacy Policy</span></a></li><li class="site-menu__item"><a href="/page/terms-conditions" target="_blank" rel="noopener" class="site-menu__link"><span class="site-menu__label">Terms & Conditions</span></a></li></ul></div><div class="site-menu__section site-menu__section--social-icons"><a href="https://www.facebook.com/ForConstructionPros" title="Visit us on Facebook" target="_blank" rel="noopener" class="social-icon-link"><span class="marko-web-icon marko-web-icon--md marko-web-icon--facebook"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Facebook icon</title><path d="M23.9981 11.9991C23.9981 5.37216 18.626 0 11.9991 0C5.37216 0 0 5.37216 0 11.9991C0 17.9882 4.38789 22.9522 10.1242 23.8524V15.4676H7.07758V11.9991H10.1242V9.35553C10.1242 6.34826 11.9156 4.68714 14.6564 4.68714C15.9692 4.68714 17.3424 4.92149 17.3424 4.92149V7.87439H15.8294C14.3388 7.87439 13.8739 8.79933 13.8739 9.74824V11.9991H17.2018L16.6698 15.4676H13.8739V23.8524C19.6103 22.9522 23.9981 17.9882 23.9981 11.9991Z"/></svg></span></a><a href="https://www.twitter.com/4ConstructnPros" title="Visit us on Twitter" target="_blank" rel="noopener" class="social-icon-link"><span class="marko-web-icon marko-web-icon--md marko-web-icon--twitter"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Twitter icon</title><path d="M23.954 4.569c-.885.389-1.83.654-2.825.775 1.014-.611 1.794-1.574 2.163-2.723-.951.555-2.005.959-3.127 1.184-.896-.959-2.173-1.559-3.591-1.559-2.717 0-4.92 2.203-4.92 4.917 0 .39.045.765.127 1.124C7.691 8.094 4.066 6.13 1.64 3.161c-.427.722-.666 1.561-.666 2.475 0 1.71.87 3.213 2.188 4.096-.807-.026-1.566-.248-2.228-.616v.061c0 2.385 1.693 4.374 3.946 4.827-.413.111-.849.171-1.296.171-.314 0-.615-.03-.916-.086.631 1.953 2.445 3.377 4.604 3.417-1.68 1.319-3.809 2.105-6.102 2.105-.39 0-.779-.023-1.17-.067 2.189 1.394 4.768 2.209 7.557 2.209 9.054 0 13.999-7.496 13.999-13.986 0-.209 0-.42-.015-.63.961-.689 1.8-1.56 2.46-2.548l-.047-.02z"/></svg></span></a><a href="https://www.linkedin.com/company/forconstructionpros" title="Visit us on Linkedin" target="_blank" rel="noopener" class="social-icon-link"><span class="marko-web-icon marko-web-icon--md marko-web-icon--linkedin"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>LinkedIn icon</title><path d="M20.447 20.452h-3.554v-5.569c0-1.328-.027-3.037-1.852-3.037-1.853 0-2.136 1.445-2.136 2.939v5.667H9.351V9h3.414v1.561h.046c.477-.9 1.637-1.85 3.37-1.85 3.601 0 4.267 2.37 4.267 5.455v6.286zM5.337 7.433c-1.144 0-2.063-.926-2.063-2.065 0-1.138.92-2.063 2.063-2.063 1.14 0 2.064.925 2.064 2.063 0 1.139-.925 2.065-2.064 2.065zm1.782 13.019H3.555V9h3.564v11.452zM22.225 0H1.771C.792 0 0 .774 0 1.729v20.542C0 23.227.792 24 1.771 24h20.451C23.2 24 24 23.227 24 22.271V1.729C24 .774 23.2 0 22.222 0h.003z"/></svg></span></a><a href="https://www.youtube.com/user/ForConstructionPros" title="Visit us on Youtube" target="_blank" rel="noopener" class="social-icon-link"><span class="marko-web-icon marko-web-icon--md marko-web-icon--youtube"><svg role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><title>YouTube icon</title><path d="M23.495 6.205a3.007 3.007 0 0 0-2.088-2.088c-1.87-.501-9.396-.501-9.396-.501s-7.507-.01-9.396.501A3.007 3.007 0 0 0 .527 6.205a31.247 31.247 0 0 0-.522 5.805 31.247 31.247 0 0 0 .522 5.783 3.007 3.007 0 0 0 2.088 2.088c1.868.502 9.396.502 9.396.502s7.506 0 9.396-.502a3.007 3.007 0 0 0 2.088-2.088 31.247 31.247 0 0 0 .5-5.783 31.247 31.247 0 0 0-.5-5.805zM9.609 15.601V8.408l6.264 3.602z"/></svg></span></a></div></div></aside><div id="div-gpt-ad-1590072144684-528"><script>googletag.cmd.push(function() { googletag.defineOutOfPageSlot('/21772951814/forconstructionpros/rental/reskin', 'div-gpt-ad-1590072144684-528').addService(googletag.pubads()); googletag.display('div-gpt-ad-1590072144684-528'); });</script></div><div class="document-container"><article class="page page--content page--content-21134411 page--content-press-release"><div class="page-wrapper page-wrapper--no-bottom-padding"><div class="page-wrapper__section"><div class="row"><div class="col"><div id="gpt-ad-lb1" class="ad-container ad-container--max-width-970 ad-container--center" data-gam-path="/21772951814/forconstructionpros/rental/lb1" data-gam-size="[[970,250],[970,90],[970,66],[728,90],[320,50],[300,50],[300,100]]" data-gam-size-mapping="[{&#34;viewport&#34;:[980,0],&#34;size&#34;:[[970,250],[970,90],[970,66],[728,90]]},{&#34;viewport&#34;:[750,0],&#34;size&#34;:[728,90]},{&#34;viewport&#34;:[320,0],&#34;size&#34;:[[300,50],[320,50],[300,100]]}]"><script>googletag.cmd.push(function() { googletag.display('gpt-ad-lb1'); });</script></div></div></div></div><div class="page-wrapper__section"><div class="row"><div class="col"><nav class="breadcrumbs" aria-label="breadcrumb"><ol class="breadcrumb"><li class="breadcrumb-item"><a href="/" title="Home">Home</a></li><li class="breadcrumb-item"><a href="/rental" title="Rental">Rental</a></li><li class="breadcrumb-item"><a href="/rental/inventory" title="Rental Inventory">Rental Inventory</a></li></ol></nav><h1 class="page-wrapper__title">Curb Roller Manufacturing Releases Eel Screed 6100</h1><p class="page-wrapper__deck">The innovative design of the Eel Screed 6100 allows contractors, rental customers, and other operators to finish concrete screeding faster and more comfortably than alternate methods.</p><div class="page-attribution-wrapper"><div class="page-dates"><div class="page-dates__content-published">May 21, 2020</div></div><div class="page-attribution"><div class="page-attribution__content-company-name"><span class="page-attribution__content-name"><a href="/concrete/equipment-products/curbers/company/10075324/curb-roller-manufacturing">Curb Roller Manufacturing</a></span></div></div></div><div class="page-image page-image--section-logo"><div class="page-image__wrapper"><img data-image-id="5e8795a785cf4871048b4585" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/rpn_logo.5e8795a7464ab.png?auto=format&amp;w=150" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/rpn_logo.5e8795a7464ab.png?auto=format&amp;dpr=2&amp;w=150 2x" class="page-image__image lazyload" alt="Rental Inventory Logo"></div></div><div id="vue-1590072144686-981"><script>CMSBrowserComponents.loadComponent('#vue-1590072144686-981', 'SocialSharing', {"url":"https://www.forconstructionpros.com/rental/inventory/press-release/21134411/curb-roller-manufacturing-curb-roller-manufacturing-releases-eel-screed-6100","providers":["email","facebook","linkedin","twitter"]});</script></div></div></div></div><div class="page-wrapper__section"><div class="row"><div data-gallery-id=21134411 class="page-contents col-lg-8 mb-3 mb-lg-0"><div class="page-image page-image--fluid-16by9 page-image--fluid"><div class="page-image__wrapper"><img data-image-id="5ec68a6d2eb95530008b484d" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/CurbRoller_EelScreed_1.5ec68a69aecaf.png?auto=format&amp;fit=crop&amp;h=288&amp;w=512" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/CurbRoller_EelScreed_1.5ec68a69aecaf.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=288&amp;w=512 2x" class="page-image__image lazyload" alt="The innovative design of the Eel Screed 6100 from Curb Roller Manufacturing allows contractors, rental customers, and other operators to finish concrete screeding faster and more comfortably than alternate methods."></div><div class="page-image__image-caption">The innovative design of the Eel Screed 6100 from Curb Roller Manufacturing allows contractors, rental customers, and other operators to finish concrete screeding faster and more comfortably than alternate methods.</div><div class="page-image__image-credit">Curb Roller Manufacturing</div></div><a href="/concrete/equipment-products/curbers/company/10075324/curb-roller-manufacturing"><div class="page-image page-image--primary-image-inline"><div class="page-image__wrapper"><img data-image-id="58e7cf01710bfc0ef094c3de" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2017/03/Curb_Roller_Logo_Vector.58d2deb330c2c.png?auto=format&amp;w=250" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2017/03/Curb_Roller_Logo_Vector.58d2deb330c2c.png?auto=format&amp;dpr=2&amp;w=250 2x" class="page-image__image lazyload" alt="Curb Roller Logo Vector 58d2deb330c2c"></div></div></a><div class="page-contact-details"></div><div id="content-body-21134411" class="page-contents__content-body"><p>Curb Roller Manufacturing has introduced the Eel Screed 6100, a corded roller screed designed for operator comfort and easy transportation. </p><p>The innovative design of the Eel Screed 6100 allows contractors, rental customers, and other operators to finish concrete screeding faster and more comfortably than alternate methods. The Eel Screed features a direct drive system, eliminating troublesome pulleys and linkage belts, and adding to the unit’s ease of maintenance.</p><p> A variable speed control, ergonomically integrated into the unit’s handle, allows working speeds between 0-300 rpm and provides ease of operation to adjust for different slump conditions or delivery rates. A single button directional change allows for fast and easy directional adjustments in confined areas or complex pours and the multi-position handle accommodates three positions for enhanced operator comfort. </p><p>The electric-powered Eel Screed requires a 120-volt, 60-hertz outlet or generator. Internal cord storage provides for easy machine transport and protects the cord from damage.  </p><p>“The Eel Screed provides an economical, feature-rich solution for concrete contractors,” said Seth Ulmer, Curb Roller Manufacturing sales manager. “The system offers the bonus features and ease of use Curb Roller is known for, but at an economical price point.”</p><p>With a lightweight design and a folding handle, the Eel Screed is easy to transport. The one-pin connection on the stainless-steel shaft and screed ends allows for fast setup, enabling operators to get to their next jobsite as quickly as possible.</p><p>Once onsite, operators simply insert the screed ends into SCH40 4-in. aluminum pipe and plug the system into a power source. The Eel Screed 6100 offers ease of operation for all experience levels. It provides a comfortable, reliable option for concrete flatwork, which is often back-breaking and exhausting. An electric screeding tool helps eliminate potential worker injuries that might come from a hands-and-knees board screeding method.  </p><p>The Eel Screed design includes a heavy-duty kickstand to avoid setting the unit in wet concrete or dust, which can be detrimental to the longevity of the machine. The Eel Screed’s premier all-steel housing protects the motor and electrical components inside from moisture, concrete, and accidental impact, increasing the life of the machine. </p><p><br></p></div><div style="clear: both;"></div><div id="vue-1590072144688-147"><script>CMSBrowserComponents.loadComponent('#vue-1590072144688-147', 'GAMInjectAds', {"selector":"#content-body-21134411","toInject":{"1750":"<div id=\"div-gpt-ad-1590072144688-514\" class=\"ad-container ad-container--max-width-300 ad-container--in-content\" data-gam-path=\"/21772951814/forconstructionpros/rental/rail1\" data-gam-size=\"[[300,250],[300,600]]\" data-gam-size-mapping=\"[{&#34;viewport&#34;:[992,0],&#34;size&#34;:[]},{&#34;viewport&#34;:[576,0],&#34;size&#34;:[[300,250],[300,600]]},{&#34;viewport&#34;:[300,0],&#34;size&#34;:[[300,250]]}]\" data-gam-collapse=\"true\"><script>googletag.cmd.push(function() { googletag.defineSlot('/21772951814/forconstructionpros/rental/rail1', [[300,250],[300,600]], 'div-gpt-ad-1590072144688-514').defineSizeMapping(googletag.sizeMapping().addSize([992,0], []).addSize([576,0], [[300,250],[300,600]]).addSize([300,0], [[300,250]]).build()).setCollapseEmptyDiv(true).addService(googletag.pubads()); googletag.display('div-gpt-ad-1590072144688-514'); });<\\/script><\\/div>","3500":"<div id=\"div-gpt-ad-1590072144688-904\" class=\"ad-container ad-container--max-width-300 ad-container--in-content\" data-gam-path=\"/21772951814/forconstructionpros/rental/rail1\" data-gam-size=\"[[300,250],[300,600]]\" data-gam-size-mapping=\"[{&#34;viewport&#34;:[992,0],&#34;size&#34;:[]},{&#34;viewport&#34;:[576,0],&#34;size&#34;:[[300,250],[300,600]]},{&#34;viewport&#34;:[300,0],&#34;size&#34;:[[300,250]]}]\" data-gam-collapse=\"true\"><script>googletag.cmd.push(function() { googletag.defineSlot('/21772951814/forconstructionpros/rental/rail1', [[300,250],[300,600]], 'div-gpt-ad-1590072144688-904').defineSizeMapping(googletag.sizeMapping().addSize([992,0], []).addSize([576,0], [[300,250],[300,600]]).addSize([300,0], [[300,250]]).build()).setCollapseEmptyDiv(true).addService(googletag.pubads()); googletag.display('div-gpt-ad-1590072144688-904'); });<\\/script><\\/div>","5250":"<div id=\"div-gpt-ad-1590072144688-179\" class=\"ad-container ad-container--max-width-300 ad-container--in-content\" data-gam-path=\"/21772951814/forconstructionpros/rental/rail1\" data-gam-size=\"[[300,250],[300,600]]\" data-gam-size-mapping=\"[{&#34;viewport&#34;:[992,0],&#34;size&#34;:[]},{&#34;viewport&#34;:[576,0],&#34;size&#34;:[[300,250],[300,600]]},{&#34;viewport&#34;:[300,0],&#34;size&#34;:[[300,250]]}]\" data-gam-collapse=\"true\"><script>googletag.cmd.push(function() { googletag.defineSlot('/21772951814/forconstructionpros/rental/rail1', [[300,250],[300,600]], 'div-gpt-ad-1590072144688-179').defineSizeMapping(googletag.sizeMapping().addSize([992,0], []).addSize([576,0], [[300,250],[300,600]]).addSize([300,0], [[300,250]]).build()).setCollapseEmptyDiv(true).addService(googletag.pubads()); googletag.display('div-gpt-ad-1590072144688-179'); });<\\/script><\\/div>","7000":"<div id=\"div-gpt-ad-1590072144688-886\" class=\"ad-container ad-container--max-width-300 ad-container--in-content\" data-gam-path=\"/21772951814/forconstructionpros/rental/rail1\" data-gam-size=\"[[300,250],[300,600]]\" data-gam-size-mapping=\"[{&#34;viewport&#34;:[992,0],&#34;size&#34;:[]},{&#34;viewport&#34;:[576,0],&#34;size&#34;:[[300,250],[300,600]]},{&#34;viewport&#34;:[300,0],&#34;size&#34;:[[300,250]]}]\" data-gam-collapse=\"true\"><script>googletag.cmd.push(function() { googletag.defineSlot('/21772951814/forconstructionpros/rental/rail1', [[300,250],[300,600]], 'div-gpt-ad-1590072144688-886').defineSizeMapping(googletag.sizeMapping().addSize([992,0], []).addSize([576,0], [[300,250],[300,600]]).addSize([300,0], [[300,250]]).build()).setCollapseEmptyDiv(true).addService(googletag.pubads()); googletag.display('div-gpt-ad-1590072144688-886'); });<\\/script><\\/div>"}});</script></div><div id="vue-1590072144688-207"><script>CMSBrowserComponents.loadComponent('#vue-1590072144688-207', 'SocialSharing', {"url":"https://www.forconstructionpros.com/rental/inventory/press-release/21134411/curb-roller-manufacturing-curb-roller-manufacturing-releases-eel-screed-6100","providers":["email","facebook","linkedin","twitter"]});</script></div><div id="omeda-content-newsletter-block" class="omeda-personalization"></div></div><aside class="col-lg-4 page-rail"><div id="gpt-ad-rail1" class="ad-container ad-container--max-width-300 ad-container--margin-auto-x-md" data-gam-path="/21772951814/forconstructionpros/rental/rail1" data-gam-size="[[300,250]]"><script>googletag.cmd.push(function() { googletag.display('gpt-ad-rail1'); });</script></div><div class="node-list node-list--flush-x node-list--flush-y"><div class="node-list__header">Latest in Rental Inventory</div><div class="node-list__nodes"><div class="node-list__node"><div data-fortnight-action="view" data-fortnight-fields="%7B%22uuid%22%3A%22f669e629-8457-492f-8dfc-6265a371c331%22%2C%22pid%22%3A%225b55e29d2360050001b7734c%22%2C%22kv%22%3A%7B%7D%7D" data-fortnight-timestamp=1590072144798 class="node node--image-right node--flush node--product-content-type"><div class="node__contents"><div style="width: 75px;min-width: 75px;height: 75px;" class="node__image-wrapper node__image-wrapper--align-top"><a data-fortnight-action="click" data-fortnight-fields="%7B%22uuid%22%3A%22f669e629-8457-492f-8dfc-6265a371c331%22%2C%22pid%22%3A%225b55e29d2360050001b7734c%22%2C%22kv%22%3A%7B%7D%7D" href="/equipment/worksite/product/21133083/ridgid-a-subsidiary-of-emerson-ridgid-air-mover" class="node__image-inner-wrapper"><img style="width: 75px;height: 75px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/AM2288RT_drying_water_0117.5ebb0d7cea255.png?auto=format&amp;fit=crop&amp;h=75&amp;w=75" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/AM2288RT_drying_water_0117.5ebb0d7cea255.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=75&amp;w=75 2x" class="node__image lazyload" alt="Am2288 Rt Drying Water 0117"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title node__title--small"><a data-fortnight-action="click" data-fortnight-fields="%7B%22uuid%22%3A%22f669e629-8457-492f-8dfc-6265a371c331%22%2C%22pid%22%3A%225b55e29d2360050001b7734c%22%2C%22kv%22%3A%7B%7D%7D" href="/equipment/worksite/product/21133083/ridgid-a-subsidiary-of-emerson-ridgid-air-mover">RIDGID Air Mover</a></h5></div><div class="node__footer node__footer--body"><div class="node__footer-right"><div>May 12, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-right node--flush node--article-content-type"><div class="node__contents"><div style="width: 75px;min-width: 75px;height: 75px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/worksite/portable-lighting/article/21132750/five-key-considerations-when-renting-a-portable-light-tower" class="node__image-inner-wrapper"><img style="width: 75px;height: 75px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/UnitedRentals_MG_7157.5eb9841e4b7d1.png?auto=format&amp;fit=crop&amp;h=75&amp;w=75" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/UnitedRentals_MG_7157.5eb9841e4b7d1.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=75&amp;w=75 2x" class="node__image lazyload" alt="United Rentals Mg 7157"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title node__title--small"><a href="/equipment/worksite/portable-lighting/article/21132750/five-key-considerations-when-renting-a-portable-light-tower">Five Key Considerations When Renting a Portable Light Tower</a></h5></div><div class="node__footer node__footer--body"><div class="node__footer-right"><div>May 11, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-right node--flush node--company-content-type"><div class="node__contents"><div style="width: 75px;min-width: 75px;height: 75px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/rental/company/21132688/elgi-north-america" class="node__image-inner-wrapper"><img style="width: 75px;height: 75px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/logo.5eb96801bfd7c.png?auto=format&amp;bg=fff&amp;fill-color=fff&amp;fit=fill&amp;h=75&amp;pad=5&amp;w=75" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/logo.5eb96801bfd7c.png?auto=format&amp;bg=fff&amp;dpr=2&amp;fill-color=fff&amp;fit=fill&amp;h=75&amp;pad=5&amp;w=75 2x" class="node__image lazyload" alt="Logo"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title node__title--small"><a href="/rental/company/21132688/elgi-north-america">ELGi North America</a></h5></div><div class="node__footer node__footer--body"><div class="node__footer-right"><div>May 11, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-right node--flush node--press-release-content-type"><div class="node__contents"><div style="width: 75px;min-width: 75px;height: 75px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/rental/inventory/drain-cleaners/press-release/21132328/general-pipe-cleaners-general-pipe-cleaners-brings-back-snakeoil-classic-for-sewer-cables-equipment" class="node__image-inner-wrapper"><img style="width: 75px;height: 75px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/General.5eb455f794d81.png?auto=format&amp;fit=crop&amp;h=75&amp;w=75" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/General.5eb455f794d81.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=75&amp;w=75 2x" class="node__image lazyload" alt="General"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title node__title--small"><a href="/rental/inventory/drain-cleaners/press-release/21132328/general-pipe-cleaners-general-pipe-cleaners-brings-back-snakeoil-classic-for-sewer-cables-equipment">General Pipe Cleaners Brings Back Snake-Oil for Sewer Cables, Equipment</a></h5></div><div class="node__footer node__footer--body"><div class="node__footer-right"><div>May 7, 2020</div></div></div></div></div></div></div></div></div><div id="gpt-ad-rail2" class="ad-container ad-container--sticky-top ad-container--max-width-300 ad-container--margin-auto-x-md" data-gam-path="/21772951814/forconstructionpros/rental/rail1" data-gam-size="[[300,600]]"><script>googletag.cmd.push(function() { googletag.display('gpt-ad-rail2'); });</script></div></aside><div id="vue-1590072144692-230"><script>CMSBrowserComponents.loadComponent('#vue-1590072144692-230', 'PhotoSwipe', {"thumbnailClickSelectors":"[data-gallery-id=\"21134411\"] [data-image-id]","items":[{"id":"5ec68a6d2eb95530008b484d","title":"The innovative design of the Eel Screed 6100 from Curb Roller Manufacturing allows contractors, rental customers, and other operators to finish concrete screeding faster and more comfortably than alternate methods.<br><small>Curb Roller Manufacturing</small>","w":1280,"h":960,"src":"https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/CurbRoller_EelScreed_1.5ec68a69aecaf.png?auto=format&h=960&w=1280"},{"id":"5ec68a6d9725e8d7068b4840","title":"The Eel Screed 6100 provides a comfortable, reliable option for concrete flatwork, which is often back-breaking and exhausting. An electric screeding tool helps eliminate costly potential worker injuries that might come from a hands-and-knees board screeding method.<br><small>Curb Roller Manufacturing</small>","w":1280,"h":960,"src":"https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/CurbRoller_EelScreed_2.5ec68a6a11a6c.png?auto=format&bg=fff&fill-color=fff&fit=fill&h=960&pad=5&w=1280"}]});</script></div></div></div><div class="page-wrapper__section page-wrapper__section--card-deck"><div class="node-list"><div class="node-list__header node-list__header--padding-y">Recommended</div></div><div class="card-deck-flow card-deck-flow--3-cols"><div class="card-deck-flow__node"><div class="node node--image-top node--flush node--card node--full-height node--news-content-type"><div class="node__contents"><div class="node__image-wrapper node__image-wrapper--align-top"><a href="/business/news/21123411/constructions-coronavirus-update-forconstructionproscom" class="node__image-inner-wrapper node__image-inner-wrapper--fluid-16by9"><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/April_2020_US_Housing_Starts.5ec4bdf0d21f7.png?auto=format&amp;fit=crop&amp;h=191&amp;w=340" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/April_2020_US_Housing_Starts.5ec4bdf0d21f7.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=191&amp;w=340 2x" class="node__image lazyload" alt="April housing starts plunged even further than economists&amp;apos; dire forecasts to a 5-year low. But data details suggest hope is not far off."></a></div><div class="node__body"><div class="node__header node__header--body"><div class="node__header-left"><div title="Business"><a href="/business">Business</a></div></div></div><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/business/news/21123411/constructions-coronavirus-update-forconstructionproscom">Construction's Coronavirus Daily Update @ForConstructionPros.com</a></h5><div class="node__text node__text--teaser"><a href="/business/news/21123411/constructions-coronavirus-update-forconstructionproscom">UPDATED 5/19/2020 -- How to protect your company and people, economic projections and all of the construction industry's COVID-19 pandemic news</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"></div><div class="node__footer-right"><div>May 19, 2020</div></div></div></div></div></div></div><div class="card-deck-flow__node"><div class="node node--image-top node--flush node--card node--full-height node--news-content-type"><div class="node__contents"><div class="node__image-wrapper node__image-wrapper--align-top"><a href="/business/news/21134291/house-oversight-investigating-trump-ouster-of-us-dot-inspector-general" class="node__image-inner-wrapper node__image-inner-wrapper--fluid-16by9"><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/US_DOT_hq_building.5ec5730804d97.png?auto=format&amp;fit=crop&amp;h=191&amp;w=340" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/US_DOT_hq_building.5ec5730804d97.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=191&amp;w=340 2x" class="node__image lazyload" alt="U.S. Department of Transportation headquarters"></a></div><div class="node__body"><div class="node__header node__header--body"><div class="node__header-left"><div title="Business"><a href="/business">Business</a></div></div></div><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/business/news/21134291/house-oversight-investigating-trump-ouster-of-us-dot-inspector-general">House Oversight Investigating Trump Ouster of US DOT Inspector General</a></h5><div class="node__text node__text--teaser"><a href="/business/news/21134291/house-oversight-investigating-trump-ouster-of-us-dot-inspector-general">Trump’s fifth watchdog firing in six weeks was probing Sec. Chao's possible conflicts of interest, after suggestions that her agency favored Kentucky, represented by her husband, Senator Mitch McConnell</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><div><a href="/conexpo/contact/10209849/larry-stewart-editor-forconstructionproscom">Larry Stewart</a></div></div></div><div class="node__footer-right"><div>May 20, 2020</div></div></div></div></div></div></div><div class="card-deck-flow__node"><div data-fortnight-action="view" data-fortnight-fields="%7B%22uuid%22%3A%2244b69ea8-2a9a-492c-98ce-a5e237d71351%22%2C%22pid%22%3A%225b55e29d2360050001b7734c%22%2C%22kv%22%3A%7B%7D%7D" data-fortnight-timestamp=1590072144749 class="node node--image-top node--flush node--card node--full-height node--news-content-type"><div class="node__contents"><div class="node__image-wrapper node__image-wrapper--align-top"><a data-fortnight-action="click" data-fortnight-fields="%7B%22uuid%22%3A%2244b69ea8-2a9a-492c-98ce-a5e237d71351%22%2C%22pid%22%3A%225b55e29d2360050001b7734c%22%2C%22kv%22%3A%7B%7D%7D" href="/blogs/construction-grade/news/21134165/april-us-housing-starts-fall-to-fiveyear-low" class="node__image-inner-wrapper node__image-inner-wrapper--fluid-16by9"><img src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/April_2020_US_Housing_Starts_Detail.5ec46b8f9ccb4.png?auto=format&amp;fit=crop&amp;h=191&amp;w=340" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/05/16x9/April_2020_US_Housing_Starts_Detail.5ec46b8f9ccb4.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=191&amp;w=340 2x" class="node__image lazyload" alt="April 2020 Us Housing Starts Detail"></a></div><div class="node__body"><div class="node__header node__header--body"><div class="node__header-left"><div title="Blogs > Construction Grade"><a href="/blogs/construction-grade">Construction Grade</a></div></div></div><div class="node__contents node__contents--body"><h5 class="node__title"><a data-fortnight-action="click" data-fortnight-fields="%7B%22uuid%22%3A%2244b69ea8-2a9a-492c-98ce-a5e237d71351%22%2C%22pid%22%3A%225b55e29d2360050001b7734c%22%2C%22kv%22%3A%7B%7D%7D" href="/blogs/construction-grade/news/21134165/april-us-housing-starts-fall-to-fiveyear-low">April US Housing Starts Fall to Five-Year Low</a></h5><div class="node__text node__text--teaser"><a data-fortnight-action="click" data-fortnight-fields="%7B%22uuid%22%3A%2244b69ea8-2a9a-492c-98ce-a5e237d71351%22%2C%22pid%22%3A%225b55e29d2360050001b7734c%22%2C%22kv%22%3A%7B%7D%7D" href="/blogs/construction-grade/news/21134165/april-us-housing-starts-fall-to-fiveyear-low">US housing construction fell significantly lower than forecast in the first full month of COVID-19 pandemic response, but the builders are already showing signs of resilience</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><div><a href="/conexpo/contact/10209849/larry-stewart-editor-forconstructionproscom">Larry Stewart</a></div></div></div><div class="node__footer-right"><div>May 19, 2020</div></div></div></div></div></div></div></div></div></div></article><div class="page page--below page--content page--content-21134411 page--content-press-release"><div id="vue-1590072144606-791"><script>CMSBrowserComponents.loadComponent('#vue-1590072144606-791', 'GAMRefreshAd', {"on":"load-more-in-view","slotId":"gpt-ad-rail-infinite"});</script></div><div class="page-wrapper"><div class="page-wrapper__section"><div class="row"><div class="col"><div id="gpt-ad-lb2" class="ad-container ad-container--max-width-970 ad-container--center" data-gam-path="/21772951814/forconstructionpros/rental/lb1" data-gam-size="[[970,250],[970,90],[970,66],[728,90],[320,50],[300,50],[300,100]]" data-gam-size-mapping="[{&#34;viewport&#34;:[980,0],&#34;size&#34;:[[970,250],[970,90],[970,66],[728,90]]},{&#34;viewport&#34;:[750,0],&#34;size&#34;:[728,90]},{&#34;viewport&#34;:[320,0],&#34;size&#34;:[[300,50],[320,50],[300,100]]}]"><script>googletag.cmd.push(function() { googletag.display('gpt-ad-lb2'); });</script></div></div></div></div><div class="page-wrapper__section"><div class="row"><div class="col-lg-8 infinite-scroll-target"><div class="node-list node-list--padding-large node-list--flush-x node-list--flush-y"><div class="node-list__header">Latest</div><div class="node-list__nodes"><div class="node-list__node"><div class="node node--image-left node--flush node--press-release-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/rental/press-release/21129100/takeuchi-announces-luby-equipment-services-as-exclusive-st-louis-dealer" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/takeuchi.5e9a07fa40441.png?auto=format&amp;bg=fff&amp;fill-color=fff&amp;fit=fill&amp;h=135&amp;pad=5&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/takeuchi.5e9a07fa40441.png?auto=format&amp;bg=fff&amp;dpr=2&amp;fill-color=fff&amp;fit=fill&amp;h=135&amp;pad=5&amp;w=240 2x" class="node__image lazyload" alt="Takeuchi"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/rental/press-release/21129100/takeuchi-announces-luby-equipment-services-as-exclusive-st-louis-dealer">Takeuchi Announces Luby Equipment Services as Exclusive St. Louis Dealer</a></h5><div class="node__text node__text--teaser"><a href="/rental/press-release/21129100/takeuchi-announces-luby-equipment-services-as-exclusive-st-louis-dealer">Luby Equipment will carry the full lineup of Takeuchi equipment, including excavators, track loaders, skid steer loaders and wheel loaders. The dealer provides sales, service, parts and rental.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"></div><div class="node__footer-right"><div>April 19, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--press-release-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/rental/press-release/21129097/tvh-parts-americas-tvh-supports-employee-pto-donations-to-those-impacted-by-covid19" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/TVH_logo.5e9a046be0380.png?auto=format&amp;bg=fff&amp;fill-color=fff&amp;fit=fill&amp;h=135&amp;pad=5&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/TVH_logo.5e9a046be0380.png?auto=format&amp;bg=fff&amp;dpr=2&amp;fill-color=fff&amp;fit=fill&amp;h=135&amp;pad=5&amp;w=240 2x" class="node__image lazyload" alt="Tvh Logo"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/rental/press-release/21129097/tvh-parts-americas-tvh-supports-employee-pto-donations-to-those-impacted-by-covid19">TVH Supports Employee PTO Donations to Those Impacted by COVID-19</a></h5><div class="node__text node__text--teaser"><a href="/rental/press-release/21129097/tvh-parts-americas-tvh-supports-employee-pto-donations-to-those-impacted-by-covid19">TVH in the Americas (TVH), a provider of replacement parts and accessories for the material handling and industrial equipment industries, is supporting employees using unused time off to those impacted by COVID-19.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/directory/company/11782055/tvh-parts-americas">TVH Parts Americas</a></div></div><div class="node__footer-right"><div>April 18, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--press-release-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/rental/press-release/21128866/united-rentals-inc-united-rentals-announces-driveup-service" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/united_rental2.5e98886a0d8a4.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/united_rental2.5e98886a0d8a4.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="United Rental2"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/rental/press-release/21128866/united-rentals-inc-united-rentals-announces-driveup-service">United Rentals Announces Drive-Up Service, Clean Equipment</a></h5><div class="node__text node__text--teaser"><a href="/rental/press-release/21128866/united-rentals-inc-united-rentals-announces-driveup-service">United Rentals is offering drive-up service to allow customers to maintain social distancing when renting equipment, which has been disinfected.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/rental/company/10075061/united-rentals-inc">United Rentals Inc.</a></div></div><div class="node__footer-right"><div>April 17, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--press-release-content-type"><div class="node__contents"><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/worksite/press-release/21128445/lohke-materieludlejning-lohke-materieludlejning-grows-fleet-with-electric-snorkel-lifts">LOHKE Materieludlejning Grows Fleet with Electric Snorkel Lifts</a></h5><div class="node__text node__text--teaser"><a href="/equipment/worksite/press-release/21128445/lohke-materieludlejning-lohke-materieludlejning-grows-fleet-with-electric-snorkel-lifts">Danish rental company, LOHKE Materieludlejning is growing its fleet with more than 130 Snorkel lifts.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/equipment/worksite/company/21128440/lohke-materieludlejning">LOHKE Materieludlejning</a></div></div><div class="node__footer-right"><div>April 15, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--press-release-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/earthmoving-compact/mini-skid-steer-track-loaders/press-release/21128381/takeuchius-takeuchi-announces-synergy-equipment-as-new-dealer" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/16x9/TW80_S2_1.5e95d18e6b381.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/16x9/TW80_S2_1.5e95d18e6b381.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Takeuchi-US, a global leader in compact equipment, has introduced Synergy Equipment as a new dealer."></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/earthmoving-compact/mini-skid-steer-track-loaders/press-release/21128381/takeuchius-takeuchi-announces-synergy-equipment-as-new-dealer">Takeuchi Announces Synergy Equipment as New Dealer</a></h5><div class="node__text node__text--teaser"><a href="/equipment/earthmoving-compact/mini-skid-steer-track-loaders/press-release/21128381/takeuchius-takeuchi-announces-synergy-equipment-as-new-dealer">Synergy Equipment will be the exclusive Takeuchi dealer supporting the Macon, Georgia market.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/equipment/earthmoving-compact/skid-steers/company/10074812/takeuchius">Takeuchi-US</a></div></div><div class="node__footer-right"><div>April 14, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--product-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/rental/inventory/product/21126995/hankison-desiccant-dryers" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/1x1/hk_RDH1550.5e8b6f4b4be71.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/1x1/hk_RDH1550.5e8b6f4b4be71.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Hk Rdh1550"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/rental/inventory/product/21126995/hankison-desiccant-dryers">Desiccant Dryers</a></h5><div class="node__text node__text--teaser"><a href="/rental/inventory/product/21126995/hankison-desiccant-dryers">The Hankison range includes a comprehensive selection of heatless regenerative desiccant dryers which have a reputation for high performance and high reliability.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/rental/inventory/company/21126993/hankison">SPX Flow</a></div></div><div class="node__footer-right"><div>April 6, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--product-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/rental/product/21126115/general-pipe-cleaners-powervee-with-automatic-cable-feed-is-faster-and-easier-to-use" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/16x9/General_Pipe_Cleaners_Power_Vee_with_Automatic_Cable_Feed.5e85f9d3753df.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/04/16x9/General_Pipe_Cleaners_Power_Vee_with_Automatic_Cable_Feed.5e85f9d3753df.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="General Pipe Cleaners Power-Vee Drain Cleaner with Automatic Cable Feed"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/rental/product/21126115/general-pipe-cleaners-powervee-with-automatic-cable-feed-is-faster-and-easier-to-use">Power-Vee® With Automatic Cable Feed Is Faster And Easier To Use</a></h5><div class="node__text node__text--teaser"><a href="/rental/product/21126115/general-pipe-cleaners-powervee-with-automatic-cable-feed-is-faster-and-easier-to-use">The simplified automatic cable feed offers an easy-to-use lever system and a cable feed rate of up to 16 feet per minute.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/rental/inventory/drain-cleaners/company/10073102/general-pipe-cleaners">General Pipe Cleaners</a></div></div><div class="node__footer-right"><div>April 2, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--press-release-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/rental/press-release/21123895/general-pipe-cleaners-general-pipe-cleaners-resumes-operations" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/generalpipecleaners_10073100.5e78ffc7508ab.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/generalpipecleaners_10073100.5e78ffc7508ab.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Generalpipecleaners 10073100"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/rental/press-release/21123895/general-pipe-cleaners-general-pipe-cleaners-resumes-operations">General Pipe Cleaners Resumes Operations</a></h5><div class="node__text node__text--teaser"><a href="/rental/press-release/21123895/general-pipe-cleaners-general-pipe-cleaners-resumes-operations">As a company that serves "essential businesses," General Pipe Cleaners has resumed operations following closure amid Coronavirus (COVID-19).</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/rental/inventory/drain-cleaners/company/10073102/general-pipe-cleaners">General Pipe Cleaners</a></div></div><div class="node__footer-right"><div>March 23, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--product-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/earthmoving-compact/mini-skid-steer-track-loaders/product/21123625/the-toro-company-toro-edingo-500-compact-utility-loader" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/Toro__e_dingo_breaker_028.5e75264fe347d.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/Toro__e_dingo_breaker_028.5e75264fe347d.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Toro E Dingo Breaker 028"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/earthmoving-compact/mini-skid-steer-track-loaders/product/21123625/the-toro-company-toro-edingo-500-compact-utility-loader">Toro e-Dingo 500 Compact Utility Loader</a></h5></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/concrete/equipment-products/company/10074891/the-toro-company">The Toro Company</a></div></div><div class="node__footer-right"><div>March 20, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--video-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/video/21123332/avant-tecno-usa-inc-video-avant-launches-full-electric-battery-powered-articulated-loader" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/lrrgbg7z_320.5e73ae4895eb7.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/lrrgbg7z_320.5e73ae4895eb7.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Lrrgbg7z 320"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/video/21123332/avant-tecno-usa-inc-video-avant-launches-full-electric-battery-powered-articulated-loader">[VIDEO] Avant Launches Full Electric Battery Powered Articulated Loader</a></h5><div class="node__text node__text--teaser"><a href="/equipment/video/21123332/avant-tecno-usa-inc-video-avant-launches-full-electric-battery-powered-articulated-loader">Avant e5 can use standard Avant attachments and it has auxiliary hydraulic outlet on front with 30 gpm flow.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/equipment/earthmoving-compact/wheel-loaders/company/10924979/avant-tecno-usa-inc">Avant Tecno USA Inc.</a></div></div><div class="node__footer-right"><div>March 19, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--video-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/video/21122954/video-how-built-robotics-autonomous-robots-help-construction" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/asgjhjng_320.5e723ffede849.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/asgjhjng_320.5e723ffede849.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Asgjhjng 320"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/video/21122954/video-how-built-robotics-autonomous-robots-help-construction">[VIDEO] How Built Robotics Autonomous Robots Help Construction</a></h5><div class="node__text node__text--teaser"><a href="/equipment/video/21122954/video-how-built-robotics-autonomous-robots-help-construction">Noah Campbell, Founder and CEO of Built Robotics, talks about the company's autonomous robots and how they help construction.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"></div><div class="node__footer-right"><div>March 18, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--video-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/video/21123254/hitachi-construction-machinery-video-zaxis-60-is-largest-compact-excavator-in-hitachis-product-offering" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/30jqqh7y_320.5e738dde2775d.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/30jqqh7y_320.5e738dde2775d.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="30jqqh7y 320"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/video/21123254/hitachi-construction-machinery-video-zaxis-60-is-largest-compact-excavator-in-hitachis-product-offering">[VIDEO] Zaxis 60 is Largest Compact Excavator in Hitachi's Product Offering</a></h5><div class="node__text node__text--teaser"><a href="/equipment/video/21123254/hitachi-construction-machinery-video-zaxis-60-is-largest-compact-excavator-in-hitachis-product-offering">Jonny Spendlove talks about Hitachi's new Zaxis 60 - the largest small class excavator it offers.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/construction-technology/company/10073288/hitachi-construction-machinery">Hitachi Construction Machinery</a></div></div><div class="node__footer-right"><div>March 19, 2020</div></div></div></div></div></div></div></div></div><section class="page page--load-more page--page-1 page--content page--content-21134411 page--content-press-release"><div id="vue-1590072144766-434"><script>CMSBrowserComponents.loadComponent('#vue-1590072144766-434', 'TriggerInViewEvent', {"eventName":"load-more-in-view","data":{"page_number":2}});</script></div><div id="div-gpt-ad-1590072144766-234" class="ad-container ad-container--max-width-300 ad-container--margin-auto-x mb-block" data-gam-path="/21772951814/forconstructionpros/rental/rail1" data-gam-size="[[300,250],[300,600]]" data-gam-size-mapping="[{&#34;viewport&#34;:[992,0],&#34;size&#34;:[]},{&#34;viewport&#34;:[300,0],&#34;size&#34;:[[300,250],[300,600]]}]" data-gam-collapse="true"><script>googletag.cmd.push(function() { googletag.defineSlot('/21772951814/forconstructionpros/rental/rail1', [[300,250],[300,600]], 'div-gpt-ad-1590072144766-234').defineSizeMapping(googletag.sizeMapping().addSize([992,0], []).addSize([300,0], [[300,250],[300,600]]).build()).setCollapseEmptyDiv(true).addService(googletag.pubads()); googletag.display('div-gpt-ad-1590072144766-234'); });</script></div><div class="node-list node-list--padding-large node-list--infinite-scroll node-list--flush-x node-list--flush-y"><div class="node-list__nodes"><div class="node-list__node"><div data-fortnight-action="view" data-fortnight-fields="%7B%22uuid%22%3A%228eeadfe5-4a62-447c-90a4-5f2388c7e9e1%22%2C%22pid%22%3A%225b55e29d2360050001b7734c%22%2C%22kv%22%3A%7B%7D%7D" data-fortnight-timestamp=1590072144800 class="node node--image-left node--flush node--video-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a data-fortnight-action="click" data-fortnight-fields="%7B%22uuid%22%3A%228eeadfe5-4a62-447c-90a4-5f2388c7e9e1%22%2C%22pid%22%3A%225b55e29d2360050001b7734c%22%2C%22kv%22%3A%7B%7D%7D" href="/equipment/video/21123101/doosan-portable-power-video-doosans-intelligent-load-management-system-prevents-wet-stacking" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/ilms.5e727dd008d4a.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/ilms.5e727dd008d4a.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Ilms"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a data-fortnight-action="click" data-fortnight-fields="%7B%22uuid%22%3A%228eeadfe5-4a62-447c-90a4-5f2388c7e9e1%22%2C%22pid%22%3A%225b55e29d2360050001b7734c%22%2C%22kv%22%3A%7B%7D%7D" href="/equipment/video/21123101/doosan-portable-power-video-doosans-intelligent-load-management-system-prevents-wet-stacking">[VIDEO] Doosan's Intelligent Load Management System Prevents Wet Stacking</a></h5><div class="node__text node__text--teaser"><a data-fortnight-action="click" data-fortnight-fields="%7B%22uuid%22%3A%228eeadfe5-4a62-447c-90a4-5f2388c7e9e1%22%2C%22pid%22%3A%225b55e29d2360050001b7734c%22%2C%22kv%22%3A%7B%7D%7D" href="/equipment/video/21123101/doosan-portable-power-video-doosans-intelligent-load-management-system-prevents-wet-stacking">Intelligent Load Management System (ILMS) is designed to improve machine performance and decrease potential downtime associated with Tier 4-compliant mobile generators in light load and fluctuating demand applications.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/equipment/worksite/company/10075979/doosan-portable-power">Doosan Portable Power</a></div></div><div class="node__footer-right"><div>March 18, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--video-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/video/21122805/bobcat-co-video-bobcat-took-a-different-approach-to-its-conexpo-2020-offering" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/Screen_Shot_2020_03_17_at_4.03.01_PM.5e713b18136ca.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/Screen_Shot_2020_03_17_at_4.03.01_PM.5e713b18136ca.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Screen Shot 2020 03 17 At 4 03 01 Pm"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/video/21122805/bobcat-co-video-bobcat-took-a-different-approach-to-its-conexpo-2020-offering">[VIDEO] Bobcat Took a Different Approach to Its CONEXPO 2020 Offering</a></h5><div class="node__text node__text--teaser"><a href="/equipment/video/21122805/bobcat-co-video-bobcat-took-a-different-approach-to-its-conexpo-2020-offering">Bobcat decided to narrow its focus at the show to its new equipment and its technology advancements.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/equipment/snow-removal-equipment/company/10075912/bobcat-co">Bobcat Co.</a></div></div><div class="node__footer-right"><div>March 17, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--video-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/video/21122796/wacker-neuson-corporation-video-wacker-neuson-et42-mini-excavator-provides-high-horsepower-in-compact-package" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/csnh57dl_320.5e712e19579e6.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/csnh57dl_320.5e712e19579e6.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Csnh57dl 320"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/video/21122796/wacker-neuson-corporation-video-wacker-neuson-et42-mini-excavator-provides-high-horsepower-in-compact-package">[VIDEO] Wacker Neuson ET42 Mini Excavator Provides High Horsepower in Compact Package</a></h5><div class="node__text node__text--teaser"><a href="/equipment/video/21122796/wacker-neuson-corporation-video-wacker-neuson-et42-mini-excavator-provides-high-horsepower-in-compact-package">John Doddo from Wacker Neuson talks about the new ET42 mini excavator.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/equipment/earthmoving-compact/skid-steers/company/10075166/wacker-neuson-corporation">Wacker Neuson Corporation</a></div></div><div class="node__footer-right"><div>March 17, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--video-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/video/21122793/wacker-neuson-corporation-video-wacker-neuson-dv60-solves-site-dumper-visibility-challenges" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/dfo2dx0d_320.5e712bcac2951.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/dfo2dx0d_320.5e712bcac2951.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Dfo2dx0d 320"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/video/21122793/wacker-neuson-corporation-video-wacker-neuson-dv60-solves-site-dumper-visibility-challenges">[VIDEO] Wacker Neuson DV60 Solves Site Dumper Visibility Challenges</a></h5><div class="node__text node__text--teaser"><a href="/equipment/video/21122793/wacker-neuson-corporation-video-wacker-neuson-dv60-solves-site-dumper-visibility-challenges">John Doddo from Wacker Neuson talks about the new DV60 Wheel Dumper. The DV60 offers the operator the ability to look in both directions.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/equipment/earthmoving-compact/skid-steers/company/10075166/wacker-neuson-corporation">Wacker Neuson Corporation</a></div></div><div class="node__footer-right"><div>March 17, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--video-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/video/21122730/case-construction-equipment-cnh-video-three-benefits-of-cases-580-ev-all-electric-backhoe" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/4wxwpw3b_320.5e71058c86dda.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/4wxwpw3b_320.5e71058c86dda.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="4wxwpw3b 320"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/video/21122730/case-construction-equipment-cnh-video-three-benefits-of-cases-580-ev-all-electric-backhoe">[VIDEO] Three Benefits of CASE's 580 EV All Electric Backhoe</a></h5><div class="node__text node__text--teaser"><a href="/equipment/video/21122730/case-construction-equipment-cnh-video-three-benefits-of-cases-580-ev-all-electric-backhoe">Ed Brenton, product marketing manager at CASE Construction Equipment, explains how low maintenance, zero emissions and reduced noise will benefit those who are first to own the 580 EV electric backhoe.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/equipment/compaction/company/10072356/case-construction-equipment-cnh">Case Construction Equipment - CNH</a></div></div><div class="node__footer-right"><div>March 17, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--video-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/video/21122440/kato-video-kato-debuts-17vxv-batterypowered-mini-excavator" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/Kato_thumb.5e6fc41e39dde.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/Kato_thumb.5e6fc41e39dde.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Kato Thumb"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/video/21122440/kato-video-kato-debuts-17vxv-batterypowered-mini-excavator">[VIDEO] Kato Debuts 17VXV Battery-powered Mini Excavator</a></h5><div class="node__text node__text--teaser"><a href="/equipment/video/21122440/kato-video-kato-debuts-17vxv-batterypowered-mini-excavator">Bart Dehaven with Kato talks about the company's two battery-powered mini excavators, the 9VXV and 17VXV.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/equipment/earthmoving-compact/mini-excavators/company/10073360/kato">KATO-CES</a></div></div><div class="node__footer-right"><div>March 16, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--video-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/video/21121637/caterpillar-cat-video-caterpillars-smart-grader-attachment-works-like-a-sideshift-without-the-weight" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/cat_smart_attach_5e02kf8j_320.5e6a69740b846.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/cat_smart_attach_5e02kf8j_320.5e6a69740b846.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Cat Smart Attach 5e02kf8j 320"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/video/21121637/caterpillar-cat-video-caterpillars-smart-grader-attachment-works-like-a-sideshift-without-the-weight">[VIDEO] Caterpillar's Smart Grader Attachment Works Like a Side-Shift without the Weight</a></h5><div class="node__text node__text--teaser"><a href="/equipment/video/21121637/caterpillar-cat-video-caterpillars-smart-grader-attachment-works-like-a-sideshift-without-the-weight">Cat's Tharen Peterson says the  side extensions on the smart grader blade for D3 skid steers can work around obstacles at much lower weight than side-shift functionality</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/equipment/earthmoving/backhoe-loaders/company/10075307/caterpillar-cat">Caterpillar - Cat</a></div></div><div class="node__footer-right"><div>March 12, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--video-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/video/21121530/takeuchius-video-takeuchi-tb220e-fully-electric-excavator" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/takeuchi_1ye87r6n_320.5e6a43e74c45f.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/takeuchi_1ye87r6n_320.5e6a43e74c45f.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Takeuchi 1ye87r6n 320"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/video/21121530/takeuchius-video-takeuchi-tb220e-fully-electric-excavator">[VIDEO] Takeuchi TB220E Fully Electric Excavator</a></h5><div class="node__text node__text--teaser"><a href="/equipment/video/21121530/takeuchius-video-takeuchi-tb220e-fully-electric-excavator">Features of Takeuchi TB220E include a 4,277-lb. operating weight, a 7-ft. 10-in. dig depth and a 3,080-lb. bucket breakout force.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/equipment/earthmoving-compact/skid-steers/company/10074812/takeuchius">Takeuchi-US</a></div></div><div class="node__footer-right"><div>March 12, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--video-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/equipment/video/21121393/kubota-tractor-corp-video-kubotas-new-scl-1000-standon-skid-steer" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/kubota_9yku4c9z_320.5e69295ca0032.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/kubota_9yku4c9z_320.5e69295ca0032.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Kubota 9yku4c9z 320"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/equipment/video/21121393/kubota-tractor-corp-video-kubotas-new-scl-1000-standon-skid-steer">[VIDEO] Kubota's New SCL 1000 Stand-on Skid Steer</a></h5><div class="node__text node__text--teaser"><a href="/equipment/video/21121393/kubota-tractor-corp-video-kubotas-new-scl-1000-standon-skid-steer">Powered by a Kubota engine with 36 in. total width and 4 psi ground pressure, the SCL 1000 has a rated operating capacity of 1,000 lb., or 35% of the tipping load.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/trucks/trucks-accessories/service-fuel-trucks/company/10073594/kubota-tractor-corp">Kubota Tractor Corp.</a></div></div><div class="node__footer-right"><div>March 11, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--press-release-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/concrete/press-release/21121106/cw-dusttech-cw-dusttech-debuts-at-conexpo" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/C_W_Full_Horizontal_Final_01.5e67dee1125c2.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/C_W_Full_Horizontal_Final_01.5e67dee1125c2.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="C&amp;amp;w Full Horizontal Final 01"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/concrete/press-release/21121106/cw-dusttech-cw-dusttech-debuts-at-conexpo">C&W DustTech Debuts at ConExpo</a></h5><div class="node__text node__text--teaser"><a href="/concrete/press-release/21121106/cw-dusttech-cw-dusttech-debuts-at-conexpo">Launches new aftermarket parts e-Commerce store for dealers and business partners.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/concrete/equipment-products/company/10076061/cw-dusttech">C&W DustTech</a></div></div><div class="node__footer-right"><div>March 10, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--press-release-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/concrete/press-release/21121105/cw-dusttech-cw-manufacturing-is-now-cw-dusttech" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/C_W_Full_Horizontal_Final_01.5e67df019afc3.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/C_W_Full_Horizontal_Final_01.5e67df019afc3.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="C&amp;amp;w Full Horizontal Final 01"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/concrete/press-release/21121105/cw-dusttech-cw-manufacturing-is-now-cw-dusttech">C&W Manufacturing is Now C&W DustTech</a></h5><div class="node__text node__text--teaser"><a href="/concrete/press-release/21121105/cw-dusttech-cw-manufacturing-is-now-cw-dusttech">New name. Same singular focus on dust.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/concrete/equipment-products/company/10076061/cw-dusttech">C&W DustTech</a></div></div><div class="node__footer-right"><div>March 10, 2020</div></div></div></div></div></div></div><div class="node-list__node"><div class="node node--image-left node--flush node--press-release-content-type"><div class="node__contents"><div style="width: 240px;min-width: 240px;height: 135px;" class="node__image-wrapper node__image-wrapper--align-top"><a href="/rental/press-release/21121085/genie-terex-awp-new-genie-lift-tools-spill-guard-promotes-clean-jobsites" class="node__image-inner-wrapper"><img style="width: 240px;height: 135px;" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/Genie_Lift_Tools_Spill_Guard_hyraulic_tray_close_up.5e67c773c8969.png?auto=format&amp;fit=crop&amp;h=135&amp;w=240" data-srcset="https://img.forconstructionpros.com/files/base/acbm/fcp/image/2020/03/16x9/Genie_Lift_Tools_Spill_Guard_hyraulic_tray_close_up.5e67c773c8969.png?auto=format&amp;dpr=2&amp;fit=crop&amp;h=135&amp;w=240 2x" class="node__image lazyload" alt="Genie Lift Tools Spill Guard Hydraulic Tray Close-Up"></a></div><div class="node__body"><div class="node__contents node__contents--body"><h5 class="node__title"><a href="/rental/press-release/21121085/genie-terex-awp-new-genie-lift-tools-spill-guard-promotes-clean-jobsites">New Genie Lift Tools™ Spill Guard Promotes Clean Jobsites</a></h5><div class="node__text node__text--teaser"><a href="/rental/press-release/21121085/genie-terex-awp-new-genie-lift-tools-spill-guard-promotes-clean-jobsites">Optional hydraulic containment solution for Genie GS-1330m scissor lifts.</a></div></div><div class="node__footer node__footer--body"><div class="node__footer-left"><div><a href="/equipment/attachments/company/10073112/genie-terex-awp">Genie - Terex AWP</a></div></div><div class="node__footer-right"><div>March 10, 2020</div></div></div></div></div></div></div></div></div><div id="vue-1590072144784-149"><script>CMSBrowserComponents.loadComponent('#vue-1590072144784-149', 'LoadMoreTrigger', {"appendTo":".infinite-scroll-target","maxPages":4,"expand":500,"pageNumber":1,"provide":{"appendTo":".infinite-scroll-target","expand":500,"componentName":"refresh-theme-latest-content-list-flow","componentInput":{"withHeader":false,"modifiers":["infinite-scroll"],"adunit":{"size":[[300,250],[300,600]],"sizeMapping":[{"viewport":[992,0],"size":[]},{"viewport":[300,0],"size":[[300,250],[300,600]]}],"path":"/21772951814/forconstructionpros/rental/rail1","modifiers":["max-width-300","margin-auto-x"]},"nativeX":{"index":0,"name":"default","aliases":["rental/inventory","rental"]}},"fragmentName":"content-latest","maxPages":4,"queryName":"website-scheduled-content","queryParams":{"sectionId":54510,"excludeContentIds":[21134411],"limit":12,"excludeContentTypes":["Company","Contact","Promotion"],"queryName":"LoadMore","after":"MjExMjEwODU"},"pageInput":{"for":"content","id":21134411,"type":"press-release"}},"show":true,"mountPoint":"/__load-more"});</script></div></section></div><aside class="col-lg-4 page-rail"><div class="follow-us"><div class="node-list"><div class="node-list__header node-list__header--padding-y">Follow Us</div></div><div class="follow-us__icons"><a href="https://www.facebook.com/ForConstructionPros" title="Visit us on Facebook" target="_blank" rel="noopener" class="social-icon-link"><span class="marko-web-icon marko-web-icon--dark marko-web-icon--xl marko-web-icon--facebook"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Facebook icon</title><path d="M23.9981 11.9991C23.9981 5.37216 18.626 0 11.9991 0C5.37216 0 0 5.37216 0 11.9991C0 17.9882 4.38789 22.9522 10.1242 23.8524V15.4676H7.07758V11.9991H10.1242V9.35553C10.1242 6.34826 11.9156 4.68714 14.6564 4.68714C15.9692 4.68714 17.3424 4.92149 17.3424 4.92149V7.87439H15.8294C14.3388 7.87439 13.8739 8.79933 13.8739 9.74824V11.9991H17.2018L16.6698 15.4676H13.8739V23.8524C19.6103 22.9522 23.9981 17.9882 23.9981 11.9991Z"/></svg></span></a><a href="https://www.twitter.com/4ConstructnPros" title="Visit us on Twitter" target="_blank" rel="noopener" class="social-icon-link"><span class="marko-web-icon marko-web-icon--dark marko-web-icon--xl marko-web-icon--twitter"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Twitter icon</title><path d="M23.954 4.569c-.885.389-1.83.654-2.825.775 1.014-.611 1.794-1.574 2.163-2.723-.951.555-2.005.959-3.127 1.184-.896-.959-2.173-1.559-3.591-1.559-2.717 0-4.92 2.203-4.92 4.917 0 .39.045.765.127 1.124C7.691 8.094 4.066 6.13 1.64 3.161c-.427.722-.666 1.561-.666 2.475 0 1.71.87 3.213 2.188 4.096-.807-.026-1.566-.248-2.228-.616v.061c0 2.385 1.693 4.374 3.946 4.827-.413.111-.849.171-1.296.171-.314 0-.615-.03-.916-.086.631 1.953 2.445 3.377 4.604 3.417-1.68 1.319-3.809 2.105-6.102 2.105-.39 0-.779-.023-1.17-.067 2.189 1.394 4.768 2.209 7.557 2.209 9.054 0 13.999-7.496 13.999-13.986 0-.209 0-.42-.015-.63.961-.689 1.8-1.56 2.46-2.548l-.047-.02z"/></svg></span></a><a href="https://www.linkedin.com/company/forconstructionpros" title="Visit us on Linkedin" target="_blank" rel="noopener" class="social-icon-link"><span class="marko-web-icon marko-web-icon--dark marko-web-icon--xl marko-web-icon--linkedin"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>LinkedIn icon</title><path d="M20.447 20.452h-3.554v-5.569c0-1.328-.027-3.037-1.852-3.037-1.853 0-2.136 1.445-2.136 2.939v5.667H9.351V9h3.414v1.561h.046c.477-.9 1.637-1.85 3.37-1.85 3.601 0 4.267 2.37 4.267 5.455v6.286zM5.337 7.433c-1.144 0-2.063-.926-2.063-2.065 0-1.138.92-2.063 2.063-2.063 1.14 0 2.064.925 2.064 2.063 0 1.139-.925 2.065-2.064 2.065zm1.782 13.019H3.555V9h3.564v11.452zM22.225 0H1.771C.792 0 0 .774 0 1.729v20.542C0 23.227.792 24 1.771 24h20.451C23.2 24 24 23.227 24 22.271V1.729C24 .774 23.2 0 22.222 0h.003z"/></svg></span></a><a href="https://www.youtube.com/user/ForConstructionPros" title="Visit us on Youtube" target="_blank" rel="noopener" class="social-icon-link"><span class="marko-web-icon marko-web-icon--dark marko-web-icon--xl marko-web-icon--youtube"><svg role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><title>YouTube icon</title><path d="M23.495 6.205a3.007 3.007 0 0 0-2.088-2.088c-1.87-.501-9.396-.501-9.396-.501s-7.507-.01-9.396.501A3.007 3.007 0 0 0 .527 6.205a31.247 31.247 0 0 0-.522 5.805 31.247 31.247 0 0 0 .522 5.783 3.007 3.007 0 0 0 2.088 2.088c1.868.502 9.396.502 9.396.502s7.506 0 9.396-.502a3.007 3.007 0 0 0 2.088-2.088 31.247 31.247 0 0 0 .5-5.783 31.247 31.247 0 0 0-.5-5.805zM9.609 15.601V8.408l6.264 3.602z"/></svg></span></a></div></div><div id="gpt-ad-rail-infinite" class="ad-container ad-container--sticky-top ad-container--max-width-300 ad-container--margin-auto-x-md" data-gam-path="/21772951814/forconstructionpros/rental/rail1" data-gam-size="[[300,250],[300,600]]" data-gam-size-mapping="[{&#34;viewport&#34;:[992,0],&#34;size&#34;:[[300,250],[300,600]]},{&#34;viewport&#34;:[0,0],&#34;size&#34;:[]}]"><script>googletag.cmd.push(function() { googletag.display('gpt-ad-rail-infinite'); });</script></div></aside></div></div></div></div></div><footer class="site-footer"><div class="site-footer__container site-footer__container--secondary"><a href="/" class="site-footer__brand"><img class="site-footer__logo lazyload" alt="For Construction Pros" src="https://base.imgix.net/files/base/acbm/fcp/image/static/logo/site_logo.png?h=45" srcset="https://base.imgix.net/files/base/acbm/fcp/image/static/logo/site_logo.png?h=90 2x"></a></div><div class="site-footer__container site-footer__container--primary"><div class="site-footer__social-icons"><a href="https://www.facebook.com/ForConstructionPros" title="Visit us on Facebook" target="_blank" rel="noopener" class="social-icon-link"><span class="marko-web-icon marko-web-icon--light marko-web-icon--xl marko-web-icon--shadow marko-web-icon--facebook"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Facebook icon</title><path d="M23.9981 11.9991C23.9981 5.37216 18.626 0 11.9991 0C5.37216 0 0 5.37216 0 11.9991C0 17.9882 4.38789 22.9522 10.1242 23.8524V15.4676H7.07758V11.9991H10.1242V9.35553C10.1242 6.34826 11.9156 4.68714 14.6564 4.68714C15.9692 4.68714 17.3424 4.92149 17.3424 4.92149V7.87439H15.8294C14.3388 7.87439 13.8739 8.79933 13.8739 9.74824V11.9991H17.2018L16.6698 15.4676H13.8739V23.8524C19.6103 22.9522 23.9981 17.9882 23.9981 11.9991Z"/></svg></span></a><a href="https://www.twitter.com/4ConstructnPros" title="Visit us on Twitter" target="_blank" rel="noopener" class="social-icon-link"><span class="marko-web-icon marko-web-icon--light marko-web-icon--xl marko-web-icon--shadow marko-web-icon--twitter"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>Twitter icon</title><path d="M23.954 4.569c-.885.389-1.83.654-2.825.775 1.014-.611 1.794-1.574 2.163-2.723-.951.555-2.005.959-3.127 1.184-.896-.959-2.173-1.559-3.591-1.559-2.717 0-4.92 2.203-4.92 4.917 0 .39.045.765.127 1.124C7.691 8.094 4.066 6.13 1.64 3.161c-.427.722-.666 1.561-.666 2.475 0 1.71.87 3.213 2.188 4.096-.807-.026-1.566-.248-2.228-.616v.061c0 2.385 1.693 4.374 3.946 4.827-.413.111-.849.171-1.296.171-.314 0-.615-.03-.916-.086.631 1.953 2.445 3.377 4.604 3.417-1.68 1.319-3.809 2.105-6.102 2.105-.39 0-.779-.023-1.17-.067 2.189 1.394 4.768 2.209 7.557 2.209 9.054 0 13.999-7.496 13.999-13.986 0-.209 0-.42-.015-.63.961-.689 1.8-1.56 2.46-2.548l-.047-.02z"/></svg></span></a><a href="https://www.linkedin.com/company/forconstructionpros" title="Visit us on Linkedin" target="_blank" rel="noopener" class="social-icon-link"><span class="marko-web-icon marko-web-icon--light marko-web-icon--xl marko-web-icon--shadow marko-web-icon--linkedin"><svg role="img" viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><title>LinkedIn icon</title><path d="M20.447 20.452h-3.554v-5.569c0-1.328-.027-3.037-1.852-3.037-1.853 0-2.136 1.445-2.136 2.939v5.667H9.351V9h3.414v1.561h.046c.477-.9 1.637-1.85 3.37-1.85 3.601 0 4.267 2.37 4.267 5.455v6.286zM5.337 7.433c-1.144 0-2.063-.926-2.063-2.065 0-1.138.92-2.063 2.063-2.063 1.14 0 2.064.925 2.064 2.063 0 1.139-.925 2.065-2.064 2.065zm1.782 13.019H3.555V9h3.564v11.452zM22.225 0H1.771C.792 0 0 .774 0 1.729v20.542C0 23.227.792 24 1.771 24h20.451C23.2 24 24 23.227 24 22.271V1.729C24 .774 23.2 0 22.222 0h.003z"/></svg></span></a><a href="https://www.youtube.com/user/ForConstructionPros" title="Visit us on Youtube" target="_blank" rel="noopener" class="social-icon-link"><span class="marko-web-icon marko-web-icon--light marko-web-icon--xl marko-web-icon--shadow marko-web-icon--youtube"><svg role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><title>YouTube icon</title><path d="M23.495 6.205a3.007 3.007 0 0 0-2.088-2.088c-1.87-.501-9.396-.501-9.396-.501s-7.507-.01-9.396.501A3.007 3.007 0 0 0 .527 6.205a31.247 31.247 0 0 0-.522 5.805 31.247 31.247 0 0 0 .522 5.783 3.007 3.007 0 0 0 2.088 2.088c1.868.502 9.396.502 9.396.502s7.506 0 9.396-.502a3.007 3.007 0 0 0 2.088-2.088 31.247 31.247 0 0 0 .5-5.783 31.247 31.247 0 0 0-.5-5.805zM9.609 15.601V8.408l6.264 3.602z"/></svg></span></a></div><ul class="site-footer__items"><li class="site-footer__item"><a href="/contact-us" class="site-footer__link"><span class="site-footer__label">Contact Us</span></a></li><li class="site-footer__item"><a href="https://www.constructionnetworkmediakit.com/" target="_blank" rel="noopener" class="site-footer__link"><span class="site-footer__label">Advertise</span></a></li><li class="site-footer__item"><a href="/page/privacy-policy" target="_blank" rel="noopener" class="site-footer__link"><span class="site-footer__label">Privacy Policy</span></a></li><li class="site-footer__item"><a href="/page/terms-conditions" target="_blank" rel="noopener" class="site-footer__link"><span class="site-footer__label">Terms & Conditions</span></a></li></ul><div class="site-footer__copyright">&copy; 2020 AC Business Media, LLC. All rights reserved.</div></div></footer><div id="vue-1590072144607-4"><script>CMSBrowserComponents.loadComponent('#vue-1590072144607-4', 'RadixIdentityDetector', {"appId":"4448cfcb-e2da-40ff-8be6-671110964914"});</script></div><div id="vue-1590072144697-308"><script>CMSBrowserComponents.loadComponent('#vue-1590072144697-308', 'GAMFixedAdBottom', {"id":"div-gpt-ad-1590072144697-336","path":"/21772951814/forconstructionpros/default/lb1","size":[[320,50],[300,50]],"sizeMapping":[{"viewport":[576,0],"size":[]},{"viewport":[320,0],"size":[[300,50],[320,50]]}],"refreshInterval":15,"scrollOffset":100});</script></div></body></html>